Laptops for 

AutoCAD

AutoCAD compatible Laptops

AutoCAD is a 2D and 3D computer-aided design software application for desktop, web, and mobile developed by Autodesk. This collection of laptops are at least capable of running AutoCAD 2021. For more information regarding the required spec for AutoCAD, see the table below,


AutoCAD Requirements

  • AutoCAD (2024)
  • AutoCAD (2023)
  • AutoCAD (2022)
  • AutoCAD (2021)

Below are the system requirements for AutoCAD 2022

Aspect

Required

Recommended

Operating System

64-bit Microsoft® Windows® 11

Windows 10 version 1809 or above

Processor

2.5–2.9 GHz processor

3+ GHz processor (base), 4+ GHz (turbo)

Memory (RAM)

8GB

32GB

Display Resolution

Conventional Displays:

1920 x 1080 with True Color


High Resolution & 4K Displays:

Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)

Display Card

2 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant

8 GB GPU with 106 GB/s Bandwidth and DirectX 12 compliant

Disk Space

10GB

10GB SSD

Pointing Device

MS-Mouse compliant

.NET Framework

.NET Framework version 4.8 or later

Below are the system requirements for AutoCAD 2022

Aspect

Required

Recommended

Operating System

64-bit Microsoft® Windows® 11 

Windows 10 version 1809 or above

Processor

2.5–2.9 GHz processor

3+ GHz processor

Memory (RAM)

8GB

16GB

Display Resolution

Conventional Displays:

1920 x 1080 with True Color


High Resolution & 4K Displays:

Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)

Display Card

1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant

4 GB GPU with 106 GB/s Bandwidth and DirectX 12 compliant

Disk Space

10GB

10GB SSD

Pointing Device

MS-Mouse compliant

.NET Framework

.NET Framework version 4.8 or later

Below are the system requirements for AutoCAD 2022

Aspect

Required

Recommended

Operating System

64-bit Microsoft® Windows® 11 and Windows 10

Processor

2.5–2.9 GHz processor

3+ GHz processor

Memory (RAM)

8GB

16GB

Display Resolution

Conventional Displays:

1920 x 1080 with True Color

High Resolution & 4K Displays:

Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)

Display Card

1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant

4 GB GPU with 106 GB/s Bandwidth and DirectX 12 compliant

Disk Space

10GB

Network

Deployment via Deployment Wizard.

The license server and all workstations that will run applications dependent on network licensing must run TCP/IP protocol.

Either Microsoft® or Novell TCP/IP protocol stacks are acceptable. Primary login on workstations may be Netware or Windows.

In addition to operating systems supported for the application, the license server will run on Windows® Server 2012 R2, Windows Server 2016, and Windows Server 2019 editions.

Pointing Device

MS-Mouse compliant

.NET Framework

.NET Framework version 4.8 or later

Below are the system requirements for AutoCAD 2021

Aspect

Required

Recommended

Operating System

64-bit Microsoft® Windows® 11, 

Windows 10, and Windows 8.1

Processor

2.5–2.9 GHz processor

3+ GHz processor

Memory (RAM)

8GB

16GB

Display Resolution

Conventional Displays:

1920 x 1080 with True Color

High Resolution & 4K Displays:

Resolutions up to 3840 x 2160 supported on Windows 10, 64-bit systems (with capable display card)

Display Card

1 GB GPU with 29 GB/s Bandwidth and DirectX 11 compliant

4 GB GPU with 106 GB/s Bandwidth and DirectX 11 compliant

Disk Space

7GB

Network

Deployment via Deployment Wizard.

The license server and all workstations that will run applications dependent on network licensing must run TCP/IP protocol.

Either Microsoft® or Novell TCP/IP protocol stacks are acceptable. Primary login on workstations may be Netware or Windows.

In addition to operating systems supported for the application, the license server will run on Windows® Server 2012 R2, Windows Server 2016, and Windows Server 2019 editions.

Pointing Device

MS-Mouse compliant

.NET Framework

.NET Framework version 4.8 or later